SU Carburettor in Cloud 1 Log Out | Topics | Search
Moderators | Register | Edit Profile

Australian RR Forums » Silver Cloud & Bentley S » SU Carburettor in Cloud 1 « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Wayne Wardman
New User
Username: wayne_wardman

Post Number: 6
Registered: 7-2003
Posted on Thursday, 16 October, 2008 - 19:05:   Edit PostDelete PostView Post/Check IP

Hi

I have recently found that my Cloud ! had no damper spring in either carburettor

I have obtained replacements stated to be correct but they are vary much longer that those in my Shadow II (8 inch) and lower diameter (1 inch).

They seem incorrect to me.

any suggestions?

Wayne
Top of pagePrevious messageNext messageBottom of page Link to this message

Paul Yorke
Prolific User
Username: paul_yorke

Post Number: 228
Registered: 6-2006
Posted on Thursday, 16 October, 2008 - 19:42:   Edit PostDelete PostView Post/Check IP

Hi Wayne,

From the top of my head - and I'm open to corrections.

Are your pistons brass? I don't think brass ones needed springs because of their weight.

If not and you have alloy pistons, it does sound like you have the correct springs.

Regards, Paul.
Top of pagePrevious messageNext messageBottom of page Link to this message

Wayne Wardman
New User
Username: wayne_wardman

Post Number: 7
Registered: 7-2003
Posted on Friday, 17 October, 2008 - 19:34:   Edit PostDelete PostView Post/Check IP

Thanks Paul

My pistons are brass
i will try with and without ssprings and report back

Wayne
Top of pagePrevious messageNext messageBottom of page Link to this message

John Budden
Experienced User
Username: johnb

Post Number: 11
Registered: 4-2006
Posted on Sunday, 19 October, 2008 - 17:00:   Edit PostDelete PostView Post/Check IP

My understanding is both are true- in the 1 3/4 there are no springs. In the 2 inch before SHF207 there were no springs but springs thereafter.
Top of pagePrevious messageNext messageBottom of page Link to this message

Wayne Wardman
New User
Username: wayne_wardman

Post Number: 8
Registered: 7-2003
Posted on Saturday, 08 November, 2008 - 19:09:   Edit PostDelete PostView Post/Check IP

Well

The springs proved to be unnecessary...

My pistons are brass...

Wayne

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Please quote Chassis Numbers for all vehicles mentioned.
Password:
E-mail:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: