Speedometer (Cloud II) Log Out | Topics | Search
Moderators | Register | Edit Profile

Australian RR Forums » Silver Cloud & Bentley S » Speedometer (Cloud II) « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Richard Greene
Frequent User
Username: benzjag

Post Number: 78
Registered: 12-2012
Posted on Friday, 16 February, 2018 - 10:09 am:   Edit PostDelete PostView Post/Check IP

Finally got the speedometer working on my 61 Cloud. When starting from stop, the needle will swing wildly from the right to left and left to right. After getting up to speed, the needle begins to work correctly. The tripometer works smoothly all the time (even when the needle is "swinging").

Any help appreciated!

Richard
Top of pagePrevious messageNext messageBottom of page Link to this message

David Balfour
Frequent User
Username: sidchrome

Post Number: 86
Registered: 2-2009
Posted on Friday, 16 February, 2018 - 10:22 am:   Edit PostDelete PostView Post/Check IP

Richard,

Your needle is likely "swinging because your speedo cable is binding. This could be caused by a kink in the cable inner and/or outer, or by a lack of lubricant or excessive wear.

What happens is the cable "winds up", and then let's go - so it slows or stops momentarily then goes fast momentarily. Thus the swinging.

If you removed the speedo cable and soaked the outer in solvent or penetrating lube, and removed the inner and cleaned and oiled it, the swinging might stop.
Top of pagePrevious messageNext messageBottom of page Link to this message

Paul Yorke
Grand Master
Username: paul_yorke

Post Number: 2009
Registered: 6-2006
Posted on Friday, 16 February, 2018 - 03:19 pm:   Edit PostDelete PostView Post/Check IP

As above but it can also be the Speedo head.

Where the cable goes into it the bushes and bearings there can gum up and wind the cable up as well.

Clean and lube.

Try the cable connected and then disconnected.

Clean and lube both.

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Please quote Chassis Numbers for all vehicles mentioned.
Password:
E-mail:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: