Sway bar rubber mounts Log Out | Topics | Search
Moderators | Register | Edit Profile

Australian RR Forums » Early Post-War » Sway bar rubber mounts « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Peter McCarthy
Unregistered guest
Posted From: 101.160.180.203
Posted on Friday, 08 February, 2013 - 04:39 pm:   Edit PostDelete PostView Post/Check IP

I bought new mount rubbers and links for the sway bar on my 1949 Mk6 special chassis B19EW. The mount rubbers are much taller than the originals and shorter along the bar. I can probably make them fit into the clamps with some spacers, but can't see how to get them over the eyes at the ends of the bar. I expected them to be split. Any suggestions please?

(Message approved by david_gore)
Top of pagePrevious messageNext messageBottom of page Link to this message

Peter McCarthy
Unregistered guest
Posted From: 101.160.180.203
Posted on Monday, 11 February, 2013 - 06:11 am:   Edit PostDelete PostView Post/Check IP

Following the above, I found that the "rubber" was much softer than it appeared and went over the eyes with some brute force and washing up liquid. I was able to compress the rubber in the clamps, which extruded it along to near the edges. I was only able to do this by replacing the bolts with longer bolts that could accommodate the initial height of the rubber block, then tightening it down. Now I worry that there will not be enough flex in the block to accommodate the rotation of the sway bar in normal use.

(Message approved by david_gore)

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Please quote Chassis Numbers for all vehicles mentioned.
Password:
E-mail:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: