COOLING ISSUES (STILL!) WITH MULSANNE... Log Out | Topics | Search
Moderators | Register | Edit Profile

Australian RR Forums » Spirit Series » COOLING ISSUES (STILL!) WITH MULSANNE S 92! « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Pedro Gomes
Frequent User
Username: portamno

Post Number: 56
Registered: 2-2018
Posted on Monday, 20 August, 2018 - 03:17:   Edit PostDelete PostView Post/Check IP

Dear All:

I have received so much feedback from questions I have posted, I am grateful! But I still have cooling issues: The auxiliary electric fans will not work.

I have used the car today, it was 35 Centigrade, about 98 Fahrenheit, with the A/C working fine...But the gauge went to the limit of the white safe area, on stop and go traffic. On the highway, temperature went down.

But the electric fans did not one time come on. I am replacing The thermostat, as the one I have is over 5 years old....I am also replacing the otter switch, which sits on top of the thermostat assembly....And which, to my limited knowledge "signal" the auxiliary electric fans once a certain temperature has been reached.

I have made a direct connection between the 2 plugs of the electric fans, and they do run!

Furthermore, I have made sure, with Dye, that there was no mixture of oil with coolant, no blown gaskets... I have already replaced the expansion bottle, the coolant level is fine...

Is there anything else I could do?

From having read (for several hours already today) the AU RR forum, It seems that the A/C system, if over-pressurized, has a sensor that will also turn on the electric fans to help the A/C? If so, would you have the part number, and where it's located, so I can also check it?

The fact of the matter is that the car, 4 years ago, before trouble started, run perfectly normal as far as cooling...Uphill or downhill, or in flat roads, winter or summer the heating gauge was right in the middle and never oscillated.

I am using a mechanic, but while honest, he does not know details on cars like Bentley's...

And to go to Bentley Portugal is just a waste of time and money. I have tried it. Several times.

Any suggestions are VERY WELCOME,

Best Regards

Pedro
Top of pagePrevious messageNext messageBottom of page Link to this message

Patrick Lockyer.
Grand Master
Username: pat_lockyer

Post Number: 1953
Registered: 9-2004
Posted on Monday, 20 August, 2018 - 04:09:   Edit PostDelete PostView Post/Check IP

Relay fault maybe, test to see if ok.
Top of pagePrevious messageNext messageBottom of page Link to this message

Pedro Gomes
Frequent User
Username: portamno

Post Number: 58
Registered: 2-2018
Posted on Thursday, 23 August, 2018 - 23:00:   Edit PostDelete PostView Post/Check IP

Dear ALL Colleagues:

Problem is completely solved! This past week-end, I went thru all your comments and suggestions....Furthermore I studied other cases, must have spent at least 6 hours doing research...

Then I came across an article "Thermostat issues and Selection by Don Elliot and Phil Birkland, which you can easily locate. Otherwise, as I printed the article, I can scan and send it.

On that article, the indicated thermostat, UE 36600, which Crewe suggested that it should be replaced every 2 years came under heavy criticism....As it's made entirely of stainless steel, and I quote "from a metallurgical standpoint, sliding stainless steel on stainless steel risks eventual galling. Galling is a process where microscopic transfer of metal from one surface to another occurs until the surfaces become roughened up and they eventually stick together" End of Quote.

Well, my (old) thermostat was more than 6 years old....

Mechanic took it out, could not really see it was "damaged" or not, but I replaced it with part number PG58252PA....This has a stainless steel middle sliding rod, but the rest is made of COPPER...So, No galling.

Took car out for a hard test yesterday, on a very warm day, in the 90's....On highway, at about 120 kms, needle just a little to the right of the middle white band, on hills it went a little more towards the end of the white band, but much further away than with the old thermostat. FURTHERMORE, when i stopped the car and let it idle the Needle went precisely to the location where it was before, in another words, it cooled down.

Finally have also read that those auxiliary fans seldom come on, as their turn-on temperature is 110 centigrade. On a hot day, the regular temperature is around 102 centigrade....

So this case is CLOSED!

I THANK YOU ALL FOR THE TIME YOU HAVE TAKEN!

Anything I can do for you in sunny Portugal, please contact me.

lofotenfish.portugal@sapo.pt

warmest Regards

Pedro

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Please quote Chassis Numbers for all vehicles mentioned.
Password:
E-mail:
Action: